Showing posts with label Cisco. Show all posts
Showing posts with label Cisco. Show all posts

Saturday, March 5, 2016

Cisco ASAv 9.5.1 200 and ASDM 7.5.1 in Workstation / ESXi

I were keeping testing Cisco ASA in Vmware environment for my own studying purpose. Recently I got ASAv 9.5.1 and installed into Vmware workstation 10 and ESXi 5.5.

Here are all related posts in this blog:
More configuration posts:
1. Download Software from Cisco Software Website:

The latest is 9.5.2 200. I am using 9.5.1 200 as an example for this post.


Wednesday, January 27, 2016

Cisco ASAv HA Configurations

Configuring high availability requires two identical ASAs connected to each other through a dedicated failover link and, optionally, a Stateful Failover link. The health of the active interfaces and units is monitored to determine if specific failover conditions are met. If those conditions are met, failover occurs.

The ASA supports two failover configurations, Active/Active failover and Active/Standby failover. Each failover configuration has its own method for determining and performing failover.

  • In Active/Standby failover, one unit is the active unit. It passes traffic. The standby unit does not actively pass traffic. When a failover occurs, the active unit fails over to the standby unit, which then becomes active. You can use Active/Standby failover for ASAs in single or multiple context mode.
  • In an Active/Active failover configuration, both ASAs can pass network traffic. Active/Active failover is only available to ASAs in multiple context mode. In Active/Active failover, you divide the security contexts on the ASA into 2 failover groups . A failover group is simply a logical group of one or more security contexts. One group is assigned to be active on the primary ASA, and the other group is assigned to be active on the secondary ASA. When a failover occurs, it occurs at the failover group level.

Both failover configurations support stateful or stateless (regular) failover.

Failover Configuration Feature Support

Feature

Active/Active

Active/Standby

Single Context Mode

No

Yes

Multiple Context Mode

Yes

Yes

Traffic Sharing Network Configurations

Yes

No

Unit Failover

Yes

Yes

Failover of Groups of Contexts

Yes

No

Failover of Individual Contexts

No

No


Related posts in this blog:
Topology:

Configuration Steps:

1. Basic ASAv Setup for ASDM and SSH Access on Both ASAv Devices

Same configuration will be on both ASAv firewalls, but with different IP address
// For ASDM Access 
interface Management0/0
 management-only
 nameif Mgmt
 security-level 100
 ip address 192.168.2.11 255.255.255.0 

http server enable
http 192.168.2.0 255.255.255.0 management


// For SSH Accss
ciscoasa(config)# crypto key generate rsa modulus 2048
INFO: The name for the keys will be:
Keypair generation process begin. Please wait...
ciscoasa(config)# write memory
Building configuration...
Cryptochecksum: 67435a18 4790aaff 7584afa7 d28c43c0 

2837 bytes copied in 0.680 secs
[OK]

ciscoasa(config)# aaa authentication ssh console LOCAL
WARNING: local database is empty! Use 'username' command to define local users.
ciscoasa(config)# username test password test


ciscoasa(config)# ssh 192.168.2.0 255.255.255.0 Mgmt
ciscoasa(config)# host ASAv-Pri

// Secondary ASAv 
ciscoasa(config)# host ASAv-Sec


2. Primary ASAv Setup
2.1 Failover Interface (G0/8)


enable
config t
failover lan unit primary
interface gigabitEthernet 0/8
no shutdown

failover lan interface LANFAIL gigabitethernet 0/8
failover interface ip LANFAIL 10.10.1.1 255.255.255.0 standby 10.10.1.2
failover key secretkey
failover link LANFAIL
exit

show failover

interface gigabitEthernet 0/8
no shutdown

exit



2.2 External Interface (G0/0)


config t
interface gigabitEthernet 0/0
nameif EXT
ip address 172.17.3.11 255.255.255.0 standby 172.17.3.12
no shutdown
exit



2.3 Internal Interface (G0/3)


interface gigabitEthernet 0/1
nameif INT
security-level 100
ip address 10.94.2.11 255.255.255.0 standby 10.94.2.12
no shutdown
exit



2.4 Verify Primary ASAv Configuration


ASAv-Pri(config)# monitor-interface EXT

ASAv-Pri(config)# monitor-interface INT

ASAv-Pri(config)# failover

ASAv-Pri(config)# show failover
Failover On
Failover unit Primary
Failover LAN Interface: LANFAIL GigabitEthernet0/8 (up)
Reconnect timeout 0:00:00
Unit Poll frequency 1 seconds, holdtime 15 seconds
Interface Poll frequency 5 seconds, holdtime 25 seconds
Interface Policy 1
Monitored Interfaces 2 of 36 maximum
MAC Address Move Notification Interval not set
Version: Ours 9.5(1)200, Mate 9.5(1)200
Last Failover at: 03:27:17 UTC Jan 27 2016
        This host: Primary - Active
                Active time: 48084 (sec)
                slot 0: empty
                  Interface mgmt (192.168.2.11): Normal (Not-Monitored)
                  Interface EXT (172.17.3.11): Normal (Monitored)
                  Interface INT (10.94.2.11): Normal (Monitored)
        Other host: Secondary - Standby Ready
                Active time: 0 (sec)
                  Interface mgmt (192.168.2.12): Normal (Not-Monitored)
                  Interface EXT (172.17.3.12): Normal (Monitored)
                  Interface INT (10.94.2.12): Normal (Monitored)

Stateful Failover Logical Update Statistics
        Link : LANFAIL GigabitEthernet0/8 (up)
        Stateful Obj    xmit       xerr       rcv        rerr
        General         16330      0          6362       0
        sys cmd         6363       0          6362       0
        up time         0          0          0          0
        RPC services    0          0          0          0
        TCP conn        0          0          0          0
        UDP conn        0          0          0          0
        ARP tbl         9963       0          0          0
        Xlate_Timeout   0          0          0          0
        IPv6 ND tbl     0          0          0          0
        VPN IKEv1 SA    0          0          0          0
        VPN IKEv1 P2    0          0          0          0
        VPN IKEv2 SA    0          0          0          0
        VPN IKEv2 P2    0          0          0          0
        VPN CTCP upd    0          0          0          0
        VPN SDI upd     0          0          0          0
        VPN DHCP upd    0          0          0          0
        SIP Session     0          0          0          0
        SIP Tx  0          0          0          0
        SIP Pinhole     0          0          0          0
        Route Session   2          0          0          0
        Router ID       0          0          0          0
        User-Identity   2          0          0          0
        CTS SGTNAME     0          0          0          0
        CTS PAC         0          0          0          0
        TrustSec-SXP    0          0          0          0
        IPv6 Route      0          0          0          0
        STS Table       0          0          0          0

        Logical Update Queue Information
                        Cur     Max     Total
        Recv Q:         0       17      6362
        Xmit Q:         0       30      42313

ASAv-Pri(config)# show failover interface
        interface LANFAIL GigabitEthernet0/8
                System IP Address: 10.10.1.1 255.255.255.0
                My IP Address    : 10.10.1.1
                Other IP Address : 10.10.1.2
ASAv-Pri(config)#



3. Secondary ASAv Configuration

3.1 Failover Interface Configuration (G0/8)


config t

no failover
failover lan unit secondary
interface gigabitEthernet 0/8
no nameif
no shutdown
failover lan interface LANFAIL gigabitEthernet 0/3

failover interface ip LANFAIL 10.10.1.1 255.255.255.0 standby 10.10.1.2
failover key secretkey
failover link LANFAIL
failover
exit

interface gigabitEthernet 0/8
no shutdown

exit


ASAv-Pri# show failover
Failover On
Failover unit Secondary
Failover LAN Interface: LANFAIL GigabitEthernet0/8 (up)
Reconnect timeout 0:00:00
Unit Poll frequency 1 seconds, holdtime 15 seconds
Interface Poll frequency 5 seconds, holdtime 25 seconds
Interface Policy 1
Monitored Interfaces 2 of 36 maximum
MAC Address Move Notification Interval not set
Version: Ours 9.5(1)200, Mate 9.5(1)200
Last Failover at: 16:22:41 UTC Jan 27 2016
        This host: Secondary - Standby Ready
                Active time: 0 (sec)
                slot 0: empty
                  Interface EXT (172.17.3.12): Normal (Monitored)
                  Interface INT (10.94.2.12): Normal (Monitored)
                  Interface mgmt (192.168.2.12): Normal (Not-Monitored)
        Other host: Primary - Active
                Active time: 48625 (sec)
                  Interface EXT (172.17.3.11): Normal (Monitored)
                  Interface INT (10.94.2.11): Normal (Monitored)
                  Interface mgmt (192.168.2.11): Normal (Not-Monitored)

Stateful Failover Logical Update Statistics
        Link : LANFAIL GigabitEthernet0/8 (up)
        Stateful Obj    xmit       xerr       rcv        rerr
        General         287        0          310        0
        sys cmd         287        0          287        0
        up time         0          0          0          0
        RPC services    0          0          0          0
        TCP conn        0          0          0          0
        UDP conn        0          0          0          0
        ARP tbl         0          0          22         0
        Xlate_Timeout   0          0          0          0
        IPv6 ND tbl     0          0          0          0
        VPN IKEv1 SA    0          0          0          0
        VPN IKEv1 P2    0          0          0          0
        VPN IKEv2 SA    0          0          0          0
        VPN IKEv2 P2    0          0          0          0
        VPN CTCP upd    0          0          0          0
        VPN SDI upd     0          0          0          0
        VPN DHCP upd    0          0          0          0
        SIP Session     0          0          0          0
        SIP Tx  0          0          0          0
        SIP Pinhole     0          0          0          0
        Route Session   0          0          0          0
        Router ID       0          0          0          0
        User-Identity   0          0          1          0
        CTS SGTNAME     0          0          0          0
        CTS PAC         0          0          0          0
        TrustSec-SXP    0          0          0          0
        IPv6 Route      0          0          0          0
        STS Table       0          0          0          0

        Logical Update Queue Information
                        Cur     Max     Total
        Recv Q:         0       17      1532
        Xmit Q:         0       1       287
ASAv-Pri#

ASAv-Pri# failover ?

  active          Make this system to be the active unit of the failover pair
  exec            Execute command on the designated unit
  reload-standby  Force standby unit to reboot
  reset           Force a unit or failover group to an unfailed state






4. Verify

After all above configuration, each time you save configuration on Primary, the configuration will copied to Secondary. When you reboot Secondary ASAv, you will see the hosname will be ASAv-Sec first then after Sync, it will automatically change to ASAv-Pri.



I reloaded the Primary ASAv and checked all interfaces on Secondary:

ASAv-Pri# show failover
Failover On
Failover unit Secondary
Failover LAN Interface: LANFAIL GigabitEthernet0/8 (up)
Reconnect timeout 0:00:00
Unit Poll frequency 1 seconds, holdtime 15 seconds
Interface Poll frequency 5 seconds, holdtime 25 seconds
Interface Policy 1
Monitored Interfaces 2 of 36 maximum
MAC Address Move Notification Interval not set
Version: Ours 9.5(1)200, Mate 9.5(1)200
Last Failover at: 17:26:37 UTC Jan 27 2016
        This host: Secondary - Active
                Active time: 161 (sec)
                slot 0: empty
                  Interface EXT (172.17.3.11): Normal (Monitored)
                  Interface INT (10.94.2.11): Normal (Monitored)
                  Interface mgmt (192.168.2.11): Normal (Not-Monitored)
        Other host: Primary - Standby Ready
                Active time: 0 (sec)
                  Interface EXT (172.17.3.12): Normal (Monitored)
                  Interface INT (10.94.2.12): Normal (Monitored)
                  Interface mgmt (192.168.2.12): Normal (Not-Monitored)

Stateful Failover Logical Update Statistics
        Link : LANFAIL GigabitEthernet0/8 (up)
        Stateful Obj    xmit       xerr       rcv        rerr
        General         531        0          563        0
        sys cmd         524        0          523        0
        up time         0          0          0          0
        RPC services    0          0          0          0
        TCP conn        0          0          0          0
        UDP conn        0          0          0          0
        ARP tbl         6          0          39         0
        Xlate_Timeout   0          0          0          0
        IPv6 ND tbl     0          0          0          0
        VPN IKEv1 SA    0          0          0          0
        VPN IKEv1 P2    0          0          0          0
        VPN IKEv2 SA    0          0          0          0
        VPN IKEv2 P2    0          0          0          0
        VPN CTCP upd    0          0          0          0
        VPN SDI upd     0          0          0          0
        VPN DHCP upd    0          0          0          0
        SIP Session     0          0          0          0
        SIP Tx  0          0          0          0
        SIP Pinhole     0          0          0          0
        Route Session   0          0          0          0
        Router ID       0          0          0          0
        User-Identity   1          0          1          0
        CTS SGTNAME     0          0          0          0
        CTS PAC         0          0          0          0
        TrustSec-SXP    0          0          0          0
        IPv6 Route      0          0          0          0
        STS Table       0          0          0          0

        Logical Update Queue Information
                        Cur     Max     Total
        Recv Q:         0       17      2683
        Xmit Q:         0       30      648
ASAv-Pri#
ASAv-Pri# show interface ip brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         172.17.3.11     YES CONFIG up                    up
GigabitEthernet0/1         unassigned      YES unset  up                    up
GigabitEthernet0/2         10.94.2.11      YES CONFIG up                    up
GigabitEthernet0/3         unassigned      YES unset  administratively down up
GigabitEthernet0/4         unassigned      YES unset  administratively down up
GigabitEthernet0/5         unassigned      YES unset  administratively down up
GigabitEthernet0/6         unassigned      YES unset  administratively down up
GigabitEthernet0/7         unassigned      YES unset  administratively down up
GigabitEthernet0/8         10.10.1.2       YES unset  up                    up
Management0/0              192.168.2.11    YES CONFIG up                    up

ASAv-Pri#


ASAv-Pri#   show version

Cisco Adaptive Security Appliance Software Version 9.5(1)200
Device Manager Version 7.5(1)

Compiled on Fri 28-Aug-15 15:56 PDT by builders
System image file is "boot:/asa951-200-smp-k8.bin"
Config file at boot was "startup-config"

ASAv-Pri up 1 hour 5 mins
failover cluster up 15 hours 54 mins

Hardware:   ASAv, 1024 MB RAM, CPU Xeon 5500 series 2294 MHz,
Model Id:   ASAv5
Internal ATA Compact Flash, 256MB
Slot 1: ATA Compact Flash, 8192MB
BIOS Flash Firmware Hub @ 0x0, 0KB


 0: Ext: Management0/0       : address is 000c.291a.f3fd, irq 10
 1: Ext: GigabitEthernet0/0  : address is 000c.291a.f307, irq 5
 2: Ext: GigabitEthernet0/1  : address is 000c.291a.f311, irq 9
 3: Ext: GigabitEthernet0/2  : address is 000c.291a.f31b, irq 11
 4: Ext: GigabitEthernet0/3  : address is 000c.291a.f325, irq 10
 5: Ext: GigabitEthernet0/4  : address is 000c.291a.f32f, irq 5
 6: Ext: GigabitEthernet0/5  : address is 000c.291a.f339, irq 9
 7: Ext: GigabitEthernet0/6  : address is 000c.291a.f343, irq 11
 8: Ext: GigabitEthernet0/7  : address is 000c.291a.f34d, irq 10
 9: Ext: GigabitEthernet0/8  : address is 000c.291a.f357, irq 5

License mode: Smart Licensing
ASAv Platform License State: Unlicensed
No active entitlement: no feature tier and no throughput level configured
*Memory resource allocation is more than the permitted limit.

Licensed features for this platform:
Maximum Physical Interfaces       : 10
Maximum VLANs                     : 25
Inside Hosts                      : Unlimited
Failover                          : Active/Standby
Encryption-DES                    : Enabled
Encryption-3DES-AES               : Enabled
Security Contexts                 : 0
GTP/GPRS                          : Disabled
AnyConnect Premium Peers          : 2
AnyConnect Essentials             : Disabled
Other VPN Peers                   : 50
Total VPN Peers                   : 50
Shared License                    : Disabled
AnyConnect for Mobile             : Disabled
AnyConnect for Cisco VPN Phone    : Disabled
Advanced Endpoint Assessment      : Disabled
Total UC Proxy Sessions           : 2
Botnet Traffic Filter             : Enabled
Cluster                           : Disabled


License mode: Smart Licensing

Failover cluster licensed features for this platform:
Maximum Physical Interfaces       : 10
Maximum VLANs                     : 25
Inside Hosts                      : Unlimited
Failover                          : Active/Standby
Encryption-DES                    : Enabled
Encryption-3DES-AES               : Enabled
Security Contexts                 : 0
GTP/GPRS                          : Disabled
AnyConnect Premium Peers          : 2
AnyConnect Essentials             : Disabled
Other VPN Peers                   : 50
Total VPN Peers                   : 50
Shared License                    : Disabled
AnyConnect for Mobile             : Disabled
AnyConnect for Cisco VPN Phone    : Disabled
Advanced Endpoint Assessment      : Disabled
Total UC Proxy Sessions           : 2
Botnet Traffic Filter             : Enabled
Cluster                           : Disabled

Licensing mode is Smart Licensing

Serial Number: 9ALU3EW6LDF

Image type          : Release
Key version         : A

Configuration last modified by enable_1 at 17:02:38.079 UTC Wed Jan 27 2016
ASAv-Pri#

ASAv-Pri# sh run
: Saved

:
: Serial Number: 9ALU3EW6LDF
: Hardware:   ASAv, 1024 MB RAM, CPU Xeon 5500 series 2294 MHz
:
ASA Version 9.5(1)200
!
hostname ASAv-Pri
enable password 8Ry2YjIyt7RRXU24 encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names
!
interface GigabitEthernet0/0
 nameif EXT
 security-level 0
 ip address 172.17.3.11 255.255.255.0 standby 172.17.3.12
!
interface GigabitEthernet0/1
 description test
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/2
 nameif INT
 security-level 100
 ip address 10.94.2.11 255.255.255.0 standby 10.94.2.12
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/6
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/7
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/8
 description LAN/STATE Failover Interface
!
interface Management0/0
 management-only
 nameif mgmt
 security-level 0
 ip address 192.168.2.11 255.255.255.0 standby 192.168.2.12
!
ftp mode passive
pager lines 23
logging enable
logging asdm informational
mtu EXT 1500
mtu INT 1500
mtu mgmt 1500
failover
failover lan unit secondary
failover lan interface LANFAIL GigabitEthernet0/8
failover key *****
failover link LANFAIL GigabitEthernet0/8
failover interface ip LANFAIL 10.10.1.1 255.255.255.0 standby 10.10.1.2
no monitor-interface mgmt
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.2.0 255.255.255.0 mgmt
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpoint _SmartCallHome_ServerCA
 no validation-usage
 crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
telnet timeout 5
ssh stricthostkeycheck
ssh 192.168.2.0 255.255.255.0 mgmt
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
username test password P4ttSyrm33SV8TYp encrypted
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect ip-options
  inspect netbios
  inspect rtsp
  inspect sunrpc
  inspect tftp
  inspect xdmcp
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect esmtp
  inspect sqlnet
  inspect sip
  inspect skinny
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum client auto
  message-length maximum 512
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous prompt 2
call-home
 profile License
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination transport-method http
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email [email protected]
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:deb136269827f21fc1c142fac079704b
: end

ASAv-Pri#




Video: Cisco ASAv 9.5(1) - High Availability Configuring 


Reference:




Wednesday, January 20, 2016

O Errors During TFTP Cisco IOS Image Copying

I were using TFTPD32 to transfer a image to Cisco 3560 switch. It was fine at the beginning then when it was almost done I got lots of O errors.

O usually indicates that a packet was received out of order and the copy process may fail.


Symptoms:


Switch#copy tftp: flash:
Address or name of remote host []? 1.1.1.2
Source filename []? c3560-ipbasek9-mz.150-2.SE9.bin
Destination filename [c3560-ipbasek9-mz.150-2.SE9.bin]?
Accessing tftp://1.1.1.2/c3560-ipbasek9-mz.150-2.SE9.bin...
Loading c3560-ipbasek9-mz.150-2.SE9.bin from 1.1.1.2 (via Vlan1): !!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!O!OOOOOO!OOOOOO!OOOOOOOO!OOOOOOOO!OOOOOOOOOO... [timed out]

%Error reading tftp://1.1.1.2/c3560-ipbasek9-mz.150-2.SE9.bin (Timed out)
Switch#

Saturday, January 16, 2016

Comparison of Cisco Integrated Services Routers: (1800,2800,3800) vs (1900,2900,3900) vs 4000

For Branch switches, please check Comparison of Cisco Switches: (2960 vs 3560), (Cisco 3560 X vs 3650 vs 3750-X vs 3850)

Cisco 2900, 3900, and 4000 (4300 and 4400) Series Integrated Services Routers can communicate directly with Cisco Unified Communications Manager, allowing for the deployment of unified communications solutions that are ideal for small and medium-sized businesses, large enterprises, and service providers that offer managed network services.

Wednesday, January 13, 2016

Cisco Switch 2960 / 3560 Password Recovery Procedures

Worked on a used cisco switch 2960 which has been configured password. Following steps have been recorded how to get into recover mode.

1. Connect Console Cable

Cisco provides a couple of ports for console access, such as Console port, Mini USB port, AUX port. I has a previous post "Using Cisco Mini USB Console Cable to Configure Cisco Switches and Routers" for Mini USB usage. Usually old fashion way to use console port is still prevailing.

Configure the baud rate and character format of the PC or terminal to match these console port default characteristics:
  • 9600 baud
  • 8 data bits
  • No parity
  • 1 stop bit


Monday, January 4, 2016

Comparison of Cisco Switches: (2960 vs 3560), (Cisco 3560 X vs 3650 vs 3750-X vs 3850)


Cisco 2960 vs 3560 Switch

2960 series switches are L2 only switches. Meaning that you can setup VLANs but you won't be able to route between then. 3500 series switches are L3 switches. Hence you will be able to route between VLANs. Basically between 2960 and 3560 main difference is Layer 3 capabilities on the 3560 range.
Cisco WS-C2960S-24TD-L
Cisco WS-C2960S-24TD-L

Thursday, December 31, 2015

Understadning Cisco Access-Lists on Switches: PACL, VACL, RACL and MACL

This 'ACLs on Switches' diagram shows PACL, VACL and RACL location and traffic direction on switch. It is clear and easy understanding.

The following explanation is from Security Features on Switches by .

Access Lists on Switches

The switch supports the following four types of ACLs for traffic filtering:
  • Router ACL
  • Port ACL
  • VLAN ACL
  • MAC ACL

Router ACL

As the name implies, Router ACLs are similar to the IOS ACL discussed in Chapter 2, "Access Control," and can be used to filter network traffic on the switched virtual interfaces (SVI). (SVI interfaces are Layer 3 interfaces on VLANs, on Layer 3 physical interfaces, and on Layer 3 EtherChannel interfaces.) Both standard and extended ACLs are supported. For more details to configure Router ACL, refer to Chapter 2.

Port ACL

Port ACLs are similar to Router ACLs but are supported on physical interfaces and configured on Layer 2 interfaces on a switch. Port ACL supports only inbound traffic filtering. Port ACL can be configured as three type access lists: standard, extended, and MAC-extended.
Processing of the Port ACL is similar to that of the Router ACLs; the switch examines ACLs associated with features configured on a given interface and permits or denies packet forwarding based on packet-matching criteria in the ACL.
When applied to a trunk port, the ACL filters traffic on all VLANs present on the trunk port. When applied to a port with voice VLAN, the ACL filters traffic on both data and voice VLANs.
The main benefit with Port ACL is that it can filter IP traffic (using IP access lists) and non-IP traffic (using MAC access list). Both types of filtering can be achieved—that is, a Layer 2 interface can have both an IP access list and a MAC access list applied to it at the same time.

VLAN ACL (VACL)

VLAN ACL (also called VLAN map) provides packet filtering for all types of traffic that are bridged within a VLAN or routed into or out of the VLAN. Unlike Router ACL, VACL is not defined by a direction (input or output). All packets entering the VLAN (bridged or routed) are checked against the VACL. It is possible to filter traffic based on the direction of the traffic by combining VACLs and Private VLAN features.
VACLs are processed in hardware, so there is no performance penalty in processing them. Therefore, they are also referred to as wire-speed ACLs. The forwarding rate remains unchanged regardless of the size of the access list because the lookup of VACLs is performed in hardware.

VACL on a Bridged Port

Figure 4-2 illustrates where the VACL is processed when VACL is applied on a bridged port for traffic from Host A in VLAN 5 that is communicating to Host B in VLAN 10 through the switch.

Figure 4-2 VACL on a Bridged Port

VACL on a Routed Port

Figure 4-3 illustrates how IOS ACL and VACL are applied on routed packets and Layer 3 switched packets. Following is the order of processing:
  1. VACL for input VLAN
  2. Input IOS ACL
  3. Output IOS ACL
  4. VACL for output VLAN

Figure 4-3 VACL on a Routed Port

Configuring VACL

Perform the following steps to configure and apply a VACL (VLAN access map) on the switch:
  1. Define the standard or extended access list to be used in VACL.
  2. Define a VLAN access map.
  3. Configure a match clause in a VLAN access map sequence.
  4. Configure an action clause in a VLAN access map sequence.
  5. Apply the VLAN access map to the specified VLANs.
  6. Display VLAN access map information.
Example 4-6 shows how to define and apply a VACL to drop packets matching access list 1 from network 192.168.1.0/24; all other packets matching access list 2 are forwarded. The VACL is applied to VLANs 5 through 10.

Example 4-6. VACL Configuration Example

Switch(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Switch(config)#access-list 2 permit any
Switch(config)#vlan access-map mymap 10
Switch(config-access-map)#match ip address 1
Switch(config-access-map)#action drop
Switch(config-access-map)#exit
Switch(config)#vlan access-map mymap 20
Switch(config-access-map)#match ip address 2
Switch(config-access-map)#action forward
Switch(config-access-map)#exit
Switch(config)# vlan filter mymap vlan-list 5-10
Switch(config-access-map)#end

Switch# show vlan access-map
Vlan access-map "mymap"  10                              
  Match clauses:                                         
    ip address: 1                                        
  Action:                                                
    drop                                                 
Vlan access-map "mymap"  20                              
  Match clauses:                                         
    ip address: 2                                        
  Action:                                                
    Forward                                              

Switch# show vlan filter
VLAN Map mymap is filtering VLANs:                       
  5-10                                                   

MAC ACL

MAC ACL, also known as Ethernet ACL, can filter non-IP traffic on a VLAN and on a physical Layer 2 interface by using MAC addresses in a named MAC extended ACL. The steps to configure a MAC ACL are similar to those of extended named ACLs. MAC ACL supports only inbound traffic filtering.
To define the MAC Extended ACL, use the mac access-list extended command. Several non-IP protocols are supported.
After the MAC ACL is created, it can be applied to a Layer 2 interface using the mac access-group [acl-name] in command to filter non-IP traffic received on the interface.
Example 4-7 shows how to define and apply a MAC ACL to drop all (non-IP) AppleTalk Address Resolution Protocol (AARP) packets, allowing all other types of traffic.

Example 4-7. MAC ACL Configuration Example

Switch(config)# mac access-list extended my-mac-acl
Switch(config-ext-macl)# deny any any aarp
Switch(config-ext-macl)# permit any any
Switch(config-ext-macl)# exit
Switch(config)# interface Fastethernet0/10
Switch(config-if)# mac access-group my-mac-acl in
Switch(config-if)# end

Saturday, December 19, 2015

Steps to Upgrade Cisco ASA IOS and ASDM

Here are steps to upgrade IOS from 8.2(1) to 9.1(6) and ASDM to 7.5.2. It is simple and straightforward. By the way these steps are working for all PIX/ASA version upgrade as well.

1. Download Software from Cisco Website
You may need to use your ASA's serial number to find out latest support IOS version and ASDM version from Cisco support site. CCO account will be needed as well.

You will have two files for this upgrade:
  • asa916-k8.bin - for ASA IOS, about 26M
  • asdm-752.bin - for ASA's ASDM , about 25M
2. Basic Configuration on ASA

Configure management interface 0/0 with ip address 10.1.13. Also you will need to set up proper nameif and security level to enable this port. After all configured, do not forget to write all configuration to flash card.


ciscoasa(config)# int management 0/0
ciscoasa(config-if)# ip address 10.1.1.1 255.255.255.0
ciscoasa(config-if)# management-only
ciscoasa(config-if)#  nameif management
INFO: Security level for "management" set to 0 by default.
ciscoasa(config-if)#  security-level 100
ciscoasa(config-if)#
ciscoasa(config)# wr
Building configuration...
Cryptochecksum: 2f6ce793 14d757a0 d226a8da db8c3472

2582 bytes copied in 3.580 secs (860 bytes/sec)
[OK]

3. TFTP configuration

Set up your computer with ip address 10.1.1.2, which is same network as your ASA management interface. Start your TFTP application with proper configuration. I am using Tftpd32 by Ph.Jounin to set up my tftp server. Make sure you are selecting right server interface if you are having multiple network interfaces. I have put downloaded IOS 9.1.6 version and ASDM into d;\ios foler.

After connected ASA's management interface with your tftp server, verify the connectivity from ASA to your TFTP server by ping-ing tftp server ip 10.1.1.2. You may need to disable your local firewall on your tftp server machine.


ciscoasa(config)# ping 10.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms


4. Copy both IOS and ASDM files from TFTP to ASA Flash 

ciscoasa(config)# copy tftp: flash:
Address or name of remote host []? 10.1.1.2
Source filename []? asa916-k8.bin
Destination filename [asa916-k8.bin]?
Accessing tftp://10.1.1.2/asa916-k8.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Writing file disk0:/asa916-k8.bin...
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
27150336 bytes copied in 30.390 secs (905011 bytes/sec)

ciscoasa(config)# copy tftp: flash:
Address or name of remote host [10.1.1.2]?
Source filename [asa916-k8.bin]? asdm-752.bin
Destination filename [asdm-752.bin]?
Accessing tftp://10.1.1.2/asdm-752.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Writing file disk0:/asdm-752.bin...
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
25627616 bytes copied in 28.700 secs (915272 bytes/sec)


5. Boot ASA with new IOS and load new ASDM image


ciscoasa(config)# boot system disk0:/asa916-k8.bin
ciscoasa(config)# asdm image disk0:/asdm-752.bin
ciscoasa(config)# wr
Building configuration...
Cryptochecksum: bab14ac0 c6d4808b 1c61875d 96255622

2646 bytes copied in 3.720 secs (882 bytes/sec)
[OK]
ciscoasa(config)#
ciscoasa(config)# reload
Proceed with reload? [confirm]
ciscoasa(config)#


***
*** --- START GRACEFUL SHUTDOWN ---
Shutting down isakmp
Shutting down webvpn
Shutting down File system



***
*** --- SHUTDOWN NOW ---
Process shutdown finished
Rebooting.....
Restarting system.


Following output is from booting console:


Booting system, please wait...


CISCO SYSTEMS
Embedded BIOS Version 1.0(11)5 08/28/08 15:11:51.82

Low Memory: 631 KB
High Memory: 3968 MB
PCI Device Table.
Bus Dev Func VendID DevID Class              Irq
 00  00  00   8086   2578  Host Bridge      
 00  01  00   8086   2579  PCI-to-PCI Bridge
 00  03  00   8086   257B  PCI-to-PCI Bridge
 00  1C  00   8086   25AE  PCI-to-PCI Bridge
 00  1D  00   8086   25A9  Serial Bus         11
 00  1D  01   8086   25AA  Serial Bus         10
 00  1D  04   8086   25AB  System          
 00  1D  05   8086   25AC  IRQ Controller  
 00  1D  07   8086   25AD  Serial Bus         9
 00  1E  00   8086   244E  PCI-to-PCI Bridge
 00  1F  00   8086   25A1  ISA Bridge      
 00  1F  02   8086   25A3  IDE Controller     11
 00  1F  03   8086   25A4  Serial Bus         5
 00  1F  05   8086   25A6  Audio              5
 02  01  00   8086   1075  Ethernet           11
 03  01  00   177D   0003  Encrypt/Decrypt    9
 03  02  00   8086   1079  Ethernet           9
 03  02  01   8086   1079  Ethernet           9
 03  03  00   8086   1079  Ethernet           9
 03  03  01   8086   1079  Ethernet           9
 04  02  00   8086   1209  Ethernet           11
 04  03  00   8086   1209  Ethernet           5

Evaluating BIOS Options ...
Launch BIOS Extension to setup ROMMON

Cisco Systems ROMMON Version (1.0(11)5) #0: Thu Aug 28 15:23:50 PDT 2008

Platform ASA5550

Use BREAK or ESC to interrupt boot.
Use SPACE to begin boot immediately.
                                             
Launching BootLoader...
Boot configuration file contains 1 entry.


Loading disk0:/asa916-k8.bin... Booting...
Platform ASA5550

Loading...
IO memory blocks requested from bigphys 32bit: 78436
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
Starting check/repair pass.
Starting verification pass.
/dev/hda1: 130 files, 11109/31180 clusters
dosfsck(/dev/hda1) returned 0
Processor memory 3166699520, Reserved memory: 157286400

Total SSMs found: 1
SSM-4GE-INC, SN JAF1335BEME, HW ver 1.0, FW ver 1.0(0)8

Total NICs found: 12
mcwa i82557 Ethernet at irq 11  MAC: 0023.ebc4.364c
mcwa i82557 Ethernet at irq  5  MAC: 0000.0001.0001
i82547GI rev00 Gigabit Ethernet @ irq11 dev 1 index 05 MAC: 0000.0001.0002
i82546GB rev03 Gigabit Ethernet @ irq09 dev 2 index 03 MAC: 0023.ebc4.364b
i82546GB rev03 Gigabit Ethernet @ irq09 dev 2 index 02 MAC: 0023.ebc4.364a
i82546GB rev03 Gigabit Ethernet @ irq09 dev 3 index 01 MAC: 0023.ebc4.3649
i82546GB rev03 Gigabit Ethernet @ irq09 dev 3 index 00 MAC: 0023.ebc4.3648
VCS7380 Gigabit Ethernet @ index 07 MAC: 0026.0b31.564c
VCS7380 Gigabit Ethernet @ index 08 MAC: 0026.0b31.564d
VCS7380 Gigabit Ethernet @ index 09 MAC: 0026.0b31.564e
VCS7380 Gigabit Ethernet @ index 10 MAC: 0026.0b31.564f
VCS7380 Gigabit Ethernet @ index 11 MAC: 0000.0003.0002

INFO: Unable to read cluster interface-mode from flash
       Writing default mode "None" to flash
Verify the activation-key, it might take a while...
Running Permanent Activation Key: 0xd41ee978 0xb495d93b 0x48934db8 0xbd7c2014 0xc502138f

Licensed features for this platform:
Maximum Physical Interfaces       : Unlimited      perpetual
Maximum VLANs                     : 400            perpetual
Inside Hosts                      : Unlimited      perpetual
Failover                          : Active/Active  perpetual
Encryption-DES                    : Enabled        perpetual
Encryption-3DES-AES               : Enabled        perpetual
Security Contexts                 : 2              perpetual
GTP/GPRS                          : Disabled       perpetual
AnyConnect Premium Peers          : 2              perpetual
AnyConnect Essentials             : Disabled       perpetual
Other VPN Peers                   : 5000           perpetual
Total VPN Peers                   : 5000           perpetual
Shared License                    : Disabled       perpetual
AnyConnect for Mobile             : Disabled       perpetual
AnyConnect for Cisco VPN Phone    : Disabled       perpetual
Advanced Endpoint Assessment      : Disabled       perpetual
UC Phone Proxy Sessions           : 2              perpetual
Total UC Proxy Sessions           : 2              perpetual
Botnet Traffic Filter             : Disabled       perpetual
Intercompany Media Engine         : Disabled       perpetual
Cluster                           : Disabled       perpetual

This platform has an ASA 5550 VPN Premium license.

Encryption hardware device : Cisco ASA-55xx on-board accelerator (revision 0x0)
                             Boot microcode        : CN1000-MC-BOOT-2.00
                             SSL/IKE microcode     : CNLite-MC-SSLm-PLUS-2_05
                             IPSec microcode       : CNlite-MC-IPSECm-MAIN-2.09

Cisco Adaptive Security Appliance Software Version 9.1(6)

  ****************************** Warning *******************************
  This product contains cryptographic features and is
  subject to United States and local country laws
  governing, import, export, transfer, and use.
  Delivery of Cisco cryptographic products does not
  imply third-party authority to import, export,
  distribute, or use encryption. Importers, exporters,
  distributors and users are responsible for compliance
  with U.S. and local country laws. By using this
  product you agree to comply with applicable laws and
  regulations. If you are unable to comply with U.S.
  and local laws, return the enclosed items immediately.

  A summary of U.S. laws governing Cisco cryptographic
  products may be found at:
  http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

  If you require further assistance please contact us by
  sending email to [email protected]
  ******************************* Warning *******************************

This product includes software developed by the OpenSSL Project
for use in the OpenSSL Toolkit (http://www.openssl.org/)
Copyright (C) 1995-1998 Eric Young ([email protected])
All rights reserved.
Copyright (c) 1998-2011 The OpenSSL Project.
All rights reserved.

This product includes software developed at the University of
California, Irvine for use in the DAV Explorer project
(http://www.ics.uci.edu/~webdav/)
Copyright (c) 1999-2005 Regents of the University of California.
All rights reserved.

Busybox, version 1.16.1, Copyright (C) 1989, 1991 Free Software Foundation, Inc.
51 Franklin St, Fifth Floor, Boston, MA 02110-1301  USA
Busybox comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

DOSFSTOOLS, version 2.11, Copyright (C) 1989, 1991 Free Software Foundation, Inc.
59 Temple Place, Suite 330, Boston, MA 02111-1307
675 Mass Ave, Cambridge, MA 02139
DOSFSTOOLS comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

grub, version 0.94, Copyright (C) 1989, 1991 Free Software Foundation, Inc.
59 Temple Place, Suite 330, Boston, MA 02111-1307
grub comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

libgcc, version 4.3, Copyright (C) 2007 Free Software Foundation, Inc.
libgcc comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

libstdc++, version 4.3, Copyright (C) 2007 Free Software Foundation, Inc.
libstdc++ comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

Linux kernel, version 2.6.29.6, Copyright (C) 1989, 1991 Free Software
Foundation, Inc.
51 Franklin St, Fifth Floor, Boston, MA 02110-1301  USA
Linux kernel comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

module-init-tools, version 3.10, Copyright (C) 1989, 1991 Free Software
Foundation, Inc.
59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
module-init-tools comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

numactl, version 2.0.3, Copyright (C) 2008 Author: Andi Kleen, SUSE Labs
Version 2.0.0 by Cliff Wickman, Chritopher Lameter and Lee Schermerhorn
numactl comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

pciutils, version 3.1.4, Copyright (C) 1989, 1991 Free Software Foundation, Inc.
51 Franklin St, Fifth Floor, Boston, MA 02110-1301  USA
pciutils comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

readline, version 5.2, Copyright (C) 1989, 1991 Free Software Foundation, Inc.
59 Temple Place, Suite 330, Boston, MA 02111 USA
readline comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

udev, version 146, Copyright (C) 1989, 1991 Free Software Foundation, Inc.
51 Franklin St, Fifth Floor, Boston, MA 02110-1301  USA
udev comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

util-linux, version 2.16.1, Copyright (C) 1989, 1991 Free Software Foundation, Inc.
The following components, built for inclusion in Busybox.
The following components from util-linux come with ABSOLUTELY NO WARRANTY.
fdisk:
  Copyright (C) 1992  A. V. Le Blanc ([email protected])
  Copyright (C) 2001,2002 Vladimir Oleynik <[email protected]> (initial bb port)
dmesg:
  Copyright 2006 Rob Landley <[email protected]>
  Copyright 2006 Bernhard Reutner-Fischer <[email protected]>
mkswap:
  Copyright 2006 Rob Landley <[email protected]>
mount:
  Copyright (C) 1995, 1996 by Bruce Perens <[email protected]>.
  Copyright (C) 1999-2004 by Erik Andersen <[email protected]>
  Copyright (C) 2005-2006 by Rob Landley <[email protected]>
umount:
  Copyright (C) 1999-2004 by Erik Andersen <[email protected]>
  Copyright (C) 2005 by Rob Landley <[email protected]>
This is free software, and you are welcome to redistribute it under the General
Public License v.2 (http://www.gnu.org/licenses/gpl-2.0.html)
See User Manual (''Licensing'') for details.

Cisco Adapative Security Appliance Software, version 9.1,
Copyright (c) 1996-2015 by Cisco Systems, Inc.
Certain components of Cisco ASA Software, Version 9.1 are licensed under the GNU
Lesser Public License (LGPL) Version 2.1.  The software code licensed under LGPL
Version 2.1 is free software that comes with ABSOLUTELY NO WARRANTY.  You can
redistribute and/or modify such LGPL code under the terms of LGPL Version 2.1
(http://www.gnu.org/licenses/lgpl-2.1.html).  See User Manual for licensing
details.

                Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

                Cisco Systems, Inc.
                170 West Tasman Drive
                San Jose, California 95134-1706

Reading from flash...
!
REAL IP MIGRATION: WARNING
In this version access-lists used in 'access-group', 'class-map',
'dynamic-filter classify-list', 'aaa match' will be migrated from
using IP address/ports as seen on interface, to their real values.
If an access-list used by these features is shared with per-user ACL
then the original access-list has to be recreated.
INFO: Note that identical IP addresses or overlapping IP ranges on
different interfaces are not detectable by automated Real IP migration.
If your deployment contains such scenarios, please verify your migrated
configuration is appropriate for those overlapping addresses/ranges.
Please also refer to the ASA 8.3 migration guide for a complete
explanation of the automated migration process.

INFO: MIGRATION - Saving the startup configuration to file

INFO: MIGRATION - Startup configuration saved to file 'flash:8_2_1_0_startup_cfg.sav'
*** Output from config line 4, "ASA Version 8.2(1) "
.
Cryptochecksum (unchanged): 46743c59 c0bc15d3 43afde7f 39783981
Real IP migration logs:
        No ACL was changed as part of Real-ip migration

INFO: Power-On Self-Test in process.
...........................................................
INFO: Power-On Self-Test complete.

INFO: MIGRATION - Saving the startup errors to file 'flash:upgrade_startup_errors_201512181715.log'
Type help or '?' for a list of available commands.
ciscoasa> en
Password:
ciscoasa#
ciscoasa#

ciscoasa# conf t
ciscoasa(config)#

***************************** NOTICE *****************************

Help to improve the ASA platform by enabling anonymous reporting,
which allows Cisco to securely receive minimal error and health
information from the device. To learn more about this feature,
please visit: http://www.cisco.com/go/smartcall

Would you like to enable anonymous error reporting to help improve
the product? [Y]es, [N]o, [A]sk later: n

In the future, if you would like to enable this feature,
issue the command "call-home reporting anonymous".

Please remember to save your configuration.

6. Verify ASDM

Configure ASA to allow ASDM client network to access ASA's management port.
ciscoasa(config)# http server enable
ciscoasa(config)# http 10.1.1.0 255.255.255.0 management
ciscoasa(config)# wr
Building configuration...
Cryptochecksum: d719ed8f 2578f2f0 20d50a04 fe506e2b

3754 bytes copied in 3.190 secs (1251 bytes/sec)
[OK]
ciscoasa(config)# 

Open your browser with url http://10.1.1.1, you should get following screen to install ASDM launcher.
 Here is log in window from ASDM Launcher. If it asks username and password, just leave it empty and press enter.



Reference: