Showing posts with label GNS3. Show all posts
Showing posts with label GNS3. Show all posts

Monday, September 29, 2014

GNS3 VoIP Lab (Cisco 3725 and CME 4.3)

Here is a simple VoIP Lab in GNS3 environment. It is only used for my lab test and recorded here for future reference.

1. Topology:

  • GNS3 Topology:


  • Logic Topology:
xp(192.168.2.60)--------C3725 Router(192.168.2.10)

2. Enviroment:


    •  Router 3725 R1's configuration in GNS3. Flash card is 32 96 MB to hold CME4.3 files.


3.  Basic Networking Setup 

  • @R1 : Show Version Information for C3725-AdventerpriseK9_IVS-M IOS, Version 12.4(15)T9.
  • @R1, Basic TCP configuration:
interface FastEthernet0/0
 ip address 192.168.2.10 255.255.255.0
 duplex auto
 speed auto
  • By default, telephony-service is not enabled: 
R1#show telephony-service
telephony-service is not enabled
  • Enable Telephony-Service by configure some commands under telephony-service.

4. Install CME on GNS3 3725 Router

  • Set up Environment:
    • C3725 Router ip is 192.168.2.10
    • XP Machine with TFTPD ip is 192.168.2.60
  • Copy cme-full-4.3.0.0.tar into C3725 Router. I tried another tftp server Pumpkin, but it gave me an error. FTP service should be faster than tftp. TFTP took 1 hour and 44 minutes to get whole package extracted. This lab is using tftp to make things simple. From C3725 router, run following three commands:
erase flash:
format flash:
archive tar /xtract tftp://192.168.2.60/cme-full-4.3.0.0.tar flash:



To be Continued:::



Notes:



Reference:

  • http://resources.intenseschool.com/ccna-voice-labs-in-gns3-with-vtgo-pc-multilab/
  • http://ciscoshizzle.blogspot.de/2012/06/cisco-voice-lab-using-gns3.html
  • http://www.i-1.nl/blog/?p=145




Sunday, May 4, 2014

GNS3 V1.0 Alpha for Linux in Vmware Workstation

Some Exciting GDS3 V1.0 Alpha feature from their website page, especially IOU Switching Support:

Alpha 2 Release - 16/04/14

  • New Dynamips IOS Support
  • Easy Idle PC Calculation and Configuration
  • IOS on UNIX Support
  • IOU Switching Support
  • Fast Topology Save and Load
  • Rapid Spanning-Tree


 1. VM Settings. Vmware Workstation has to be at least 10.0.


2. Login Window

username : root
password : cisco

username : gns3
password : cisco




3. Start GNS3 server and client

After log in with account gns3, open an terminal window and start gns3server first by entering following command
gns3@gns3-iouvm ~ $ su -
Password:  
gns3-iouvm ~ # cd gns3-server-master/
gns3-iouvm gns3-server-master # gns3server

Open another terminal window to start gns3 client:

gns3@gns3-iouvm ~ $ su -
Password: 
gns3-iouvm ~ # cd gns3-gui-master/
gns3-iouvm gns3-gui-master # gns3




4. IOU Upload Page



5. 设置GNS3自动启动

This is from the post of Netemu:
登录Linux后,点击左下角的“Menu“,再点击从上往下数第三个图标,选择系统设置。点击“Startup Programs”,再点击“Add”
添加开机启动:
内容
第一个:name: GNS3
Command: /usr/local/bin/gns3
Comment: GNS3 GUI
点击:“Save”

第二个:name : GNS3Server
Command: /usr/local/bin/gns3server
Comment : Gns3Server
点击:“Save”

再点击"Close"

设置完成后重新启动,就可以实现开机启动GNS3了。

Note: Thanks the following posts for downloading address. 


  1. (重磅炸弹)GNS3 V1.0 Alpha for Linux
  2. 升级到 GNS3 V1 Alpha 3





Saturday, June 8, 2013

Basic MPLS Lab on GNS3

Topology:
IOS:  c3640-jk9s-mz.124-16.bin

GNS3 IOS Configuration:

Changed XTERM to gnome-terminal for better copy&paste feature:

In GNS3 Preference , replaced
xterm -T %d -e 'telnet %h %p' >/dev/null 2>&1 &
with
gnome-terminal --command='telnet %h %p' >/dev/null 2>&1 &


R1:
interface Serial0/0
 ip address 10.1.12.1 255.255.255.0
 mpls ip
interface Ethernet1/0
 ip address 10.1.13.1 255.255.255.0
 mpls ip
router eigrp 100
 network 10.1.12.0 0.0.0.255
 network 10.1.13.0 0.0.0.255
 auto-summary


R2:
interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 mpls ip
interface Ethernet1/0
 ip address 10.1.24.2 255.255.255.0
 half-duplex
 mpls ip
router eigrp 100
 network 10.1.12.0 0.0.0.255
 network 10.1.24.0 0.0.0.255
 auto-summary


R3:
interface Ethernet1/0
 ip address 10.1.13.3 255.255.255.0
 half-duplex
 mpls ip
router eigrp 100
 network 10.1.13.0 0.0.0.255
 auto-summary



R4;
interface Ethernet1/0
 ip address 10.1.24.4 255.255.255.0
 half-duplex
 mpls ip
router eigrp 100
 network 10.1.24.0 0.0.0.255
 auto-summary

Results:
R1# show mpls ldp neighbor 
    Peer LDP Ident: 10.1.24.2:0; Local LDP Ident 10.1.13.1:0
TCP connection: 10.1.24.2.56937 - 10.1.13.1.646
State: Oper; Msgs sent/rcvd: 45/46; Downstream
Up time: 00:35:42
LDP discovery sources:
 Serial0/0, Src IP addr: 10.1.12.2
        Addresses bound to peer LDP Ident:
          10.1.12.2       10.1.24.2       
    Peer LDP Ident: 10.1.13.3:0; Local LDP Ident 10.1.13.1:0
TCP connection: 10.1.13.3.37365 - 10.1.13.1.646
State: Oper; Msgs sent/rcvd: 46/46; Downstream
Up time: 00:35:20
LDP discovery sources:
 Ethernet1/0, Src IP addr: 10.1.13.3
        Addresses bound to peer LDP Ident:
          10.1.13.3  


Cisco MPLS IOS for GNS3

Here are listed working IOS for MPLS LAB on GNS3:
  • c3640-jk9s-mz.124-16
  • c3640-jk9s-mz.124-16a
  • c3640-jk9o3s-mz.123-14.T7
  • c7200-adventerprisek9-mz.124-11.T
  • c3725-adventerprisek9-mz.124-15.T10

Note: c3640-jk9s-mz.124-16是学习Gisco过程中最我们最常用IOS,此IOS不单单支持路由交换实验,同时还支持IPv6、VPN、VOip、MPLS-VPN 等,所以人们通常称之为全能型IOS。





NetSec Youtube Videos