Showing posts with label Cisco. Show all posts
Showing posts with label Cisco. Show all posts

Wednesday, September 6, 2017

Cisco IOS Command Tips and Tricks - Part 2

Cisco IOS command list is getting longer , and it has been split into two posts:

21. Auto secure

Cisco also provides a One-step lockdown-like feature at the command line! This feature is called AutoSecure. It uses the command shown below:

auto secure [management | forwarding] [no-interact | full] [ntp | login | ssh | firewall | tcp-intercept]


22. Change Site-to-Site VPN Idle time out to 5 minutes

For IOS Router

R1(config)#crypto ipsec security-association idle-time 300


For ASA

ASA1(config)#group-policy GP_1.1.1.2 attributes
ASA1(config-group-policy)#vpn-idle-timeout 300

ASA1(config-group-policy)#vpn-session-timeout none

Monday, March 27, 2017

Cisco Switch 2960x Memory Increasing Issue Troubleshooting - Memory Leak

Symptoms 

Our network monitoring software found memory usage on some new production switches keep increasing. Those switches are Cisco 2960X and coming with 15.0(2) EX3 IOS.

As we know there are two types of memory in Cisco IOS: process memory and IO memory.
  • When a feature is enable on an IOS device (e.g. PIM, HSRP, and etc), IOS allocates process memory for the process.
  • IO memory is used when a software switched traffic hits the CPU. The CPU allocates IO memory to store the frame temporarily.
Our case is process memory increasing. What we need to do is to find out which process.

Wednesday, October 26, 2016

Cisco Free Lab Website - dCloud

Cisco dCloud has been moved to version 1.5 , now it is at version 2.

Cisco dCloud lab as a service platform provides self-service training, demonstration and lab capabilities for Cisco partners. Learn about this free 24/7/365 resource which provides multiple labs in all Cisco architectures, plus documentation and instructions for conducting on-site demonstrations. For anybody to sell/buy/use Cisco products, Cisco dCloud is a great place to practice configuring.
What DCloud does is give you the ability to test, demonstrate and run 131 different labs, demos and sandboxes.


Experience a Cisco solution in dCloud:
  • Browse to Cisco dCloud. Select the location closest to you and then log in using your Cisco.com credentials.

Wednesday, October 19, 2016

Cisco Active Advisor - CAA

Cisco Active Advisor is a free online cloud service that automates network discovery and analysis of your network inventory. Cisco Active Advisor reduces the overall risk of your network administration by keeping you up-to-date on:

  • Warranty and service contract status
  • Product advisories, including Product Security Incident Response Teams (PSIRTs) and field notices
  • End-of-life milestones for hardware and software
Cisco Active Advisor log in with your Cisco CCO account:

Monday, October 17, 2016

Cisco Catalyst 2960X and 2960S Stacking

Working on stacking two Cisco 2060X switches recently, and two 2960X Stack module and 0.5m stacking cables received today. Product name is C2960X-STACK= and description is Catalyst 2960-X FlexStack Plus Stacking Module optional. Part Number is CMUCAEGBAA.



Sunday, September 25, 2016

Cisco ASA Tips and Tricks - 5500-X Series Software 9.x Configuration Notes

This post is using Cisco ASA 5515-X with software version 9.1(2) as configuration example. Here are some basic steps I recorded during configuring it.

Related posts in this blog:

Friday, August 5, 2016

Native VLAN mismatch Error on Access Port

Cisco switches always have VLAN 1 as the default VLAN, which is needed for many protocol communication between switches like spanning-tree protocol for instance. Unfortunately you can't change or even delete the default VLAN, it is mandatory.
The native VLAN is the only VLAN which is not tagged in a trunk, in other words, native VLAN frames are transmitted unchanged.
Per default the native VLAN is VLAN 1 but you can change that.


Monday, August 1, 2016

Cisco CCP Installation and Basic Configuration

Cisco Configuration Professional (Cisco CP) is a GUI based device management tool for Cisco access routers. This tool simplifies routing, firewall, IPS, VPN, unified communications, WAN and LAN configuration through GUI based easy-to-use wizards. It has been used to replace obsolete SDM (Security Device Manager) product.

Cisco Configuration Professional offers smart wizards and advanced configuration support for LAN and WAN interfaces, Network Address Translation (NAT), stateful and application firewall policy, IPS, IPSec and SSL VPN, QoS, and Cisco Network Admission Control policy features. The firewall wizard allows a single-step deployment of high, medium, or low firewall policy settings. IT managers can easily organize and manage multiple routers at a single site.

Wednesday, July 20, 2016

Recover Cisco Device using TFTP Server or External Card from a Corrupt or Missing Image or in Rommon Mode

Cisco Switch usually is quite robust and not give me hard time. When it happens, it happens. What I met is a situation Cisco 4500 switch got into Rommon mode and I have to find a quickest way to get in back in production before the maintenance window ends.

The related posts in this blog:


Tuesday, June 14, 2016

Windows Network Policy Server Basic Radius Configuration for Cisco devices

RADIUS Traffic 

RADIUS server configuration on Cisco IOS is performed in two steps, one set of commnads are defined within the AAA paradigm and other set is run with the “radius” commands. The aaa configurations on the Cisco IOS needs to be done with named method lists or the default list can be used. The simplest way to start with the configurations is to use the built-in default method lists.


1. Configuration on Cisco Switches and Routers

Friday, June 3, 2016

Password Recovery for Cisco Router 2900


I have to reset one Cisco 2901 router to factory default. Unfortunately no one knows user name and password.

Cisco documentation Password Recovery Procedure for the Cisco 2900 Integrated Services Router has listed all steps, but not enough detail how to "Remove the compact flash that is on the rear of the router."

I understand Cisco 2900 series is using a different way to do password recovery than a usual way by press 'Break' key during booting process. Cisco 2900 will automatically boot into ROMMOM mode after you removed Compact Flash card. But how to remove CF card from the rear of router, it does not say enough from Password Recovery Procedure for the Cisco 2900 Integrated Services Router.

Here are what I figured out by using a flat head screw driver. Lets find out where the compact flash card locates from following photo:




Thursday, March 24, 2016

Cisco IOS Command Tips and Tricks - Part 1


This post is used to collect some small tips and tricks I found during my daily work. Since the list is getting longer  and longer, I am splitting it into two posts:

1. Basic Troubleshooting Commands

Ping
Traceroute
Telnet
Show interfaces (show interfaces GigabitEthernet 3/6)
Show ip interface
Show ip route
Show running-config
Show startup-config
show ip sockets
show conn
show tcp brief

2. Archive Command

  • Configuration Change Logging and Save a copy of current configuration on local when write memory
archive
!!log all commands
log config
logging enable
logging size 200
notify syslog contenttype plaintext
hidekeys
path flash:backup-
maximum 8
write-memory
  • Compare Startup-Configuration with Running-configuration

R1#show archive config differences 
!Contextual Config Diffs:
!No changes were found

  • show archive log config all
  • show archive

Saturday, March 5, 2016

Installing Cisco Cloud Services Router CSR 1000V in Vmware

The Cisco CSR 1000V Series lowers the barriers to enterprise adoption of a hybrid cloud model by extending the enterprise WAN to provider-hosted clouds.
Primary features include:
  • Flexible virtual form factor designed for multi-tenant, provider-hosted clouds
  • Complete, hypervisor-isolated, multi-service router instance for each tenant
  • Proven, familiar, enterprise-class Cisco IOS Software networking services
  • Feature and operational consistency with Cisco physical form-factor routers
  • Component of end-to-end WAN architecture with Cisco Integrated Services Routers and Cisco Aggregation Services Routers
Primary use cases include:
  • Secure VPN gateway
  • MPLS WAN termination
  • Data center network extension
  • Control and traffic redirection
Primary Benefits:
  • Direct connectivity improves the response time of cloud-hosted applications
  • Private WAN integration improves security, performance, and predictability
  • Enterprise control, visibility, and policy consistency reduce security risks
  • Feature consistency and product familiarity improve operational efficiency
  • Extension of the data center network to a cloud simplifies application on-boarding

1. Download CSR 1000v Software:
you can start to download either one of following package from this page (Cisco IOS XE Software Link)

  • csr1000v-universalk9.03.12.00.S.154-2.S-std.ova
  • csr1000v-universalk9.03.12.00.S.154-2.S-std.iso

Keep this in mind, CSR1000v itself comes with a 60 day license for 50Mbps throughput. After that expires it drops to 2.5Mbps.

Cisco ASAv 9.5.1 200 and ASDM 7.5.1 in Workstation / ESXi

I were keeping testing Cisco ASA in Vmware environment for my own studying purpose. Recently I got ASAv 9.5.1 and installed into Vmware workstation 10 and ESXi 5.5.

Here are all related posts in this blog:
More configuration posts:
1. Download Software from Cisco Software Website:

The latest is 9.5.2 200. I am using 9.5.1 200 as an example for this post.


Wednesday, January 27, 2016

Cisco ASAv HA Configurations

Configuring high availability requires two identical ASAs connected to each other through a dedicated failover link and, optionally, a Stateful Failover link. The health of the active interfaces and units is monitored to determine if specific failover conditions are met. If those conditions are met, failover occurs.

The ASA supports two failover configurations, Active/Active failover and Active/Standby failover. Each failover configuration has its own method for determining and performing failover.

  • In Active/Standby failover, one unit is the active unit. It passes traffic. The standby unit does not actively pass traffic. When a failover occurs, the active unit fails over to the standby unit, which then becomes active. You can use Active/Standby failover for ASAs in single or multiple context mode.
  • In an Active/Active failover configuration, both ASAs can pass network traffic. Active/Active failover is only available to ASAs in multiple context mode. In Active/Active failover, you divide the security contexts on the ASA into 2 failover groups . A failover group is simply a logical group of one or more security contexts. One group is assigned to be active on the primary ASA, and the other group is assigned to be active on the secondary ASA. When a failover occurs, it occurs at the failover group level.

Both failover configurations support stateful or stateless (regular) failover.

Failover Configuration Feature Support

Feature

Active/Active

Active/Standby

Single Context Mode

No

Yes

Multiple Context Mode

Yes

Yes

Traffic Sharing Network Configurations

Yes

No

Unit Failover

Yes

Yes

Failover of Groups of Contexts

Yes

No

Failover of Individual Contexts

No

No


Related posts in this blog:
Topology:

Configuration Steps:

1. Basic ASAv Setup for ASDM and SSH Access on Both ASAv Devices

Same configuration will be on both ASAv firewalls, but with different IP address
// For ASDM Access 
interface Management0/0
 management-only
 nameif Mgmt
 security-level 100
 ip address 192.168.2.11 255.255.255.0 

http server enable
http 192.168.2.0 255.255.255.0 management


// For SSH Accss
ciscoasa(config)# crypto key generate rsa modulus 2048
INFO: The name for the keys will be:
Keypair generation process begin. Please wait...
ciscoasa(config)# write memory
Building configuration...
Cryptochecksum: 67435a18 4790aaff 7584afa7 d28c43c0 

2837 bytes copied in 0.680 secs
[OK]

ciscoasa(config)# aaa authentication ssh console LOCAL
WARNING: local database is empty! Use 'username' command to define local users.
ciscoasa(config)# username test password test


ciscoasa(config)# ssh 192.168.2.0 255.255.255.0 Mgmt
ciscoasa(config)# host ASAv-Pri

// Secondary ASAv 
ciscoasa(config)# host ASAv-Sec


2. Primary ASAv Setup
2.1 Failover Interface (G0/8)


enable
config t
failover lan unit primary
interface gigabitEthernet 0/8
no shutdown

failover lan interface LANFAIL gigabitethernet 0/8
failover interface ip LANFAIL 10.10.1.1 255.255.255.0 standby 10.10.1.2
failover key secretkey
failover link LANFAIL
exit

show failover

interface gigabitEthernet 0/8
no shutdown

exit



2.2 External Interface (G0/0)


config t
interface gigabitEthernet 0/0
nameif EXT
ip address 172.17.3.11 255.255.255.0 standby 172.17.3.12
no shutdown
exit



2.3 Internal Interface (G0/3)


interface gigabitEthernet 0/1
nameif INT
security-level 100
ip address 10.94.2.11 255.255.255.0 standby 10.94.2.12
no shutdown
exit



2.4 Verify Primary ASAv Configuration


ASAv-Pri(config)# monitor-interface EXT

ASAv-Pri(config)# monitor-interface INT

ASAv-Pri(config)# failover

ASAv-Pri(config)# show failover
Failover On
Failover unit Primary
Failover LAN Interface: LANFAIL GigabitEthernet0/8 (up)
Reconnect timeout 0:00:00
Unit Poll frequency 1 seconds, holdtime 15 seconds
Interface Poll frequency 5 seconds, holdtime 25 seconds
Interface Policy 1
Monitored Interfaces 2 of 36 maximum
MAC Address Move Notification Interval not set
Version: Ours 9.5(1)200, Mate 9.5(1)200
Last Failover at: 03:27:17 UTC Jan 27 2016
        This host: Primary - Active
                Active time: 48084 (sec)
                slot 0: empty
                  Interface mgmt (192.168.2.11): Normal (Not-Monitored)
                  Interface EXT (172.17.3.11): Normal (Monitored)
                  Interface INT (10.94.2.11): Normal (Monitored)
        Other host: Secondary - Standby Ready
                Active time: 0 (sec)
                  Interface mgmt (192.168.2.12): Normal (Not-Monitored)
                  Interface EXT (172.17.3.12): Normal (Monitored)
                  Interface INT (10.94.2.12): Normal (Monitored)

Stateful Failover Logical Update Statistics
        Link : LANFAIL GigabitEthernet0/8 (up)
        Stateful Obj    xmit       xerr       rcv        rerr
        General         16330      0          6362       0
        sys cmd         6363       0          6362       0
        up time         0          0          0          0
        RPC services    0          0          0          0
        TCP conn        0          0          0          0
        UDP conn        0          0          0          0
        ARP tbl         9963       0          0          0
        Xlate_Timeout   0          0          0          0
        IPv6 ND tbl     0          0          0          0
        VPN IKEv1 SA    0          0          0          0
        VPN IKEv1 P2    0          0          0          0
        VPN IKEv2 SA    0          0          0          0
        VPN IKEv2 P2    0          0          0          0
        VPN CTCP upd    0          0          0          0
        VPN SDI upd     0          0          0          0
        VPN DHCP upd    0          0          0          0
        SIP Session     0          0          0          0
        SIP Tx  0          0          0          0
        SIP Pinhole     0          0          0          0
        Route Session   2          0          0          0
        Router ID       0          0          0          0
        User-Identity   2          0          0          0
        CTS SGTNAME     0          0          0          0
        CTS PAC         0          0          0          0
        TrustSec-SXP    0          0          0          0
        IPv6 Route      0          0          0          0
        STS Table       0          0          0          0

        Logical Update Queue Information
                        Cur     Max     Total
        Recv Q:         0       17      6362
        Xmit Q:         0       30      42313

ASAv-Pri(config)# show failover interface
        interface LANFAIL GigabitEthernet0/8
                System IP Address: 10.10.1.1 255.255.255.0
                My IP Address    : 10.10.1.1
                Other IP Address : 10.10.1.2
ASAv-Pri(config)#



3. Secondary ASAv Configuration

3.1 Failover Interface Configuration (G0/8)


config t

no failover
failover lan unit secondary
interface gigabitEthernet 0/8
no nameif
no shutdown
failover lan interface LANFAIL gigabitEthernet 0/3

failover interface ip LANFAIL 10.10.1.1 255.255.255.0 standby 10.10.1.2
failover key secretkey
failover link LANFAIL
failover
exit

interface gigabitEthernet 0/8
no shutdown

exit


ASAv-Pri# show failover
Failover On
Failover unit Secondary
Failover LAN Interface: LANFAIL GigabitEthernet0/8 (up)
Reconnect timeout 0:00:00
Unit Poll frequency 1 seconds, holdtime 15 seconds
Interface Poll frequency 5 seconds, holdtime 25 seconds
Interface Policy 1
Monitored Interfaces 2 of 36 maximum
MAC Address Move Notification Interval not set
Version: Ours 9.5(1)200, Mate 9.5(1)200
Last Failover at: 16:22:41 UTC Jan 27 2016
        This host: Secondary - Standby Ready
                Active time: 0 (sec)
                slot 0: empty
                  Interface EXT (172.17.3.12): Normal (Monitored)
                  Interface INT (10.94.2.12): Normal (Monitored)
                  Interface mgmt (192.168.2.12): Normal (Not-Monitored)
        Other host: Primary - Active
                Active time: 48625 (sec)
                  Interface EXT (172.17.3.11): Normal (Monitored)
                  Interface INT (10.94.2.11): Normal (Monitored)
                  Interface mgmt (192.168.2.11): Normal (Not-Monitored)

Stateful Failover Logical Update Statistics
        Link : LANFAIL GigabitEthernet0/8 (up)
        Stateful Obj    xmit       xerr       rcv        rerr
        General         287        0          310        0
        sys cmd         287        0          287        0
        up time         0          0          0          0
        RPC services    0          0          0          0
        TCP conn        0          0          0          0
        UDP conn        0          0          0          0
        ARP tbl         0          0          22         0
        Xlate_Timeout   0          0          0          0
        IPv6 ND tbl     0          0          0          0
        VPN IKEv1 SA    0          0          0          0
        VPN IKEv1 P2    0          0          0          0
        VPN IKEv2 SA    0          0          0          0
        VPN IKEv2 P2    0          0          0          0
        VPN CTCP upd    0          0          0          0
        VPN SDI upd     0          0          0          0
        VPN DHCP upd    0          0          0          0
        SIP Session     0          0          0          0
        SIP Tx  0          0          0          0
        SIP Pinhole     0          0          0          0
        Route Session   0          0          0          0
        Router ID       0          0          0          0
        User-Identity   0          0          1          0
        CTS SGTNAME     0          0          0          0
        CTS PAC         0          0          0          0
        TrustSec-SXP    0          0          0          0
        IPv6 Route      0          0          0          0
        STS Table       0          0          0          0

        Logical Update Queue Information
                        Cur     Max     Total
        Recv Q:         0       17      1532
        Xmit Q:         0       1       287
ASAv-Pri#

ASAv-Pri# failover ?

  active          Make this system to be the active unit of the failover pair
  exec            Execute command on the designated unit
  reload-standby  Force standby unit to reboot
  reset           Force a unit or failover group to an unfailed state






4. Verify

After all above configuration, each time you save configuration on Primary, the configuration will copied to Secondary. When you reboot Secondary ASAv, you will see the hosname will be ASAv-Sec first then after Sync, it will automatically change to ASAv-Pri.



I reloaded the Primary ASAv and checked all interfaces on Secondary:

ASAv-Pri# show failover
Failover On
Failover unit Secondary
Failover LAN Interface: LANFAIL GigabitEthernet0/8 (up)
Reconnect timeout 0:00:00
Unit Poll frequency 1 seconds, holdtime 15 seconds
Interface Poll frequency 5 seconds, holdtime 25 seconds
Interface Policy 1
Monitored Interfaces 2 of 36 maximum
MAC Address Move Notification Interval not set
Version: Ours 9.5(1)200, Mate 9.5(1)200
Last Failover at: 17:26:37 UTC Jan 27 2016
        This host: Secondary - Active
                Active time: 161 (sec)
                slot 0: empty
                  Interface EXT (172.17.3.11): Normal (Monitored)
                  Interface INT (10.94.2.11): Normal (Monitored)
                  Interface mgmt (192.168.2.11): Normal (Not-Monitored)
        Other host: Primary - Standby Ready
                Active time: 0 (sec)
                  Interface EXT (172.17.3.12): Normal (Monitored)
                  Interface INT (10.94.2.12): Normal (Monitored)
                  Interface mgmt (192.168.2.12): Normal (Not-Monitored)

Stateful Failover Logical Update Statistics
        Link : LANFAIL GigabitEthernet0/8 (up)
        Stateful Obj    xmit       xerr       rcv        rerr
        General         531        0          563        0
        sys cmd         524        0          523        0
        up time         0          0          0          0
        RPC services    0          0          0          0
        TCP conn        0          0          0          0
        UDP conn        0          0          0          0
        ARP tbl         6          0          39         0
        Xlate_Timeout   0          0          0          0
        IPv6 ND tbl     0          0          0          0
        VPN IKEv1 SA    0          0          0          0
        VPN IKEv1 P2    0          0          0          0
        VPN IKEv2 SA    0          0          0          0
        VPN IKEv2 P2    0          0          0          0
        VPN CTCP upd    0          0          0          0
        VPN SDI upd     0          0          0          0
        VPN DHCP upd    0          0          0          0
        SIP Session     0          0          0          0
        SIP Tx  0          0          0          0
        SIP Pinhole     0          0          0          0
        Route Session   0          0          0          0
        Router ID       0          0          0          0
        User-Identity   1          0          1          0
        CTS SGTNAME     0          0          0          0
        CTS PAC         0          0          0          0
        TrustSec-SXP    0          0          0          0
        IPv6 Route      0          0          0          0
        STS Table       0          0          0          0

        Logical Update Queue Information
                        Cur     Max     Total
        Recv Q:         0       17      2683
        Xmit Q:         0       30      648
ASAv-Pri#
ASAv-Pri# show interface ip brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         172.17.3.11     YES CONFIG up                    up
GigabitEthernet0/1         unassigned      YES unset  up                    up
GigabitEthernet0/2         10.94.2.11      YES CONFIG up                    up
GigabitEthernet0/3         unassigned      YES unset  administratively down up
GigabitEthernet0/4         unassigned      YES unset  administratively down up
GigabitEthernet0/5         unassigned      YES unset  administratively down up
GigabitEthernet0/6         unassigned      YES unset  administratively down up
GigabitEthernet0/7         unassigned      YES unset  administratively down up
GigabitEthernet0/8         10.10.1.2       YES unset  up                    up
Management0/0              192.168.2.11    YES CONFIG up                    up

ASAv-Pri#


ASAv-Pri#   show version

Cisco Adaptive Security Appliance Software Version 9.5(1)200
Device Manager Version 7.5(1)

Compiled on Fri 28-Aug-15 15:56 PDT by builders
System image file is "boot:/asa951-200-smp-k8.bin"
Config file at boot was "startup-config"

ASAv-Pri up 1 hour 5 mins
failover cluster up 15 hours 54 mins

Hardware:   ASAv, 1024 MB RAM, CPU Xeon 5500 series 2294 MHz,
Model Id:   ASAv5
Internal ATA Compact Flash, 256MB
Slot 1: ATA Compact Flash, 8192MB
BIOS Flash Firmware Hub @ 0x0, 0KB


 0: Ext: Management0/0       : address is 000c.291a.f3fd, irq 10
 1: Ext: GigabitEthernet0/0  : address is 000c.291a.f307, irq 5
 2: Ext: GigabitEthernet0/1  : address is 000c.291a.f311, irq 9
 3: Ext: GigabitEthernet0/2  : address is 000c.291a.f31b, irq 11
 4: Ext: GigabitEthernet0/3  : address is 000c.291a.f325, irq 10
 5: Ext: GigabitEthernet0/4  : address is 000c.291a.f32f, irq 5
 6: Ext: GigabitEthernet0/5  : address is 000c.291a.f339, irq 9
 7: Ext: GigabitEthernet0/6  : address is 000c.291a.f343, irq 11
 8: Ext: GigabitEthernet0/7  : address is 000c.291a.f34d, irq 10
 9: Ext: GigabitEthernet0/8  : address is 000c.291a.f357, irq 5

License mode: Smart Licensing
ASAv Platform License State: Unlicensed
No active entitlement: no feature tier and no throughput level configured
*Memory resource allocation is more than the permitted limit.

Licensed features for this platform:
Maximum Physical Interfaces       : 10
Maximum VLANs                     : 25
Inside Hosts                      : Unlimited
Failover                          : Active/Standby
Encryption-DES                    : Enabled
Encryption-3DES-AES               : Enabled
Security Contexts                 : 0
GTP/GPRS                          : Disabled
AnyConnect Premium Peers          : 2
AnyConnect Essentials             : Disabled
Other VPN Peers                   : 50
Total VPN Peers                   : 50
Shared License                    : Disabled
AnyConnect for Mobile             : Disabled
AnyConnect for Cisco VPN Phone    : Disabled
Advanced Endpoint Assessment      : Disabled
Total UC Proxy Sessions           : 2
Botnet Traffic Filter             : Enabled
Cluster                           : Disabled


License mode: Smart Licensing

Failover cluster licensed features for this platform:
Maximum Physical Interfaces       : 10
Maximum VLANs                     : 25
Inside Hosts                      : Unlimited
Failover                          : Active/Standby
Encryption-DES                    : Enabled
Encryption-3DES-AES               : Enabled
Security Contexts                 : 0
GTP/GPRS                          : Disabled
AnyConnect Premium Peers          : 2
AnyConnect Essentials             : Disabled
Other VPN Peers                   : 50
Total VPN Peers                   : 50
Shared License                    : Disabled
AnyConnect for Mobile             : Disabled
AnyConnect for Cisco VPN Phone    : Disabled
Advanced Endpoint Assessment      : Disabled
Total UC Proxy Sessions           : 2
Botnet Traffic Filter             : Enabled
Cluster                           : Disabled

Licensing mode is Smart Licensing

Serial Number: 9ALU3EW6LDF

Image type          : Release
Key version         : A

Configuration last modified by enable_1 at 17:02:38.079 UTC Wed Jan 27 2016
ASAv-Pri#

ASAv-Pri# sh run
: Saved

:
: Serial Number: 9ALU3EW6LDF
: Hardware:   ASAv, 1024 MB RAM, CPU Xeon 5500 series 2294 MHz
:
ASA Version 9.5(1)200
!
hostname ASAv-Pri
enable password 8Ry2YjIyt7RRXU24 encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names
!
interface GigabitEthernet0/0
 nameif EXT
 security-level 0
 ip address 172.17.3.11 255.255.255.0 standby 172.17.3.12
!
interface GigabitEthernet0/1
 description test
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/2
 nameif INT
 security-level 100
 ip address 10.94.2.11 255.255.255.0 standby 10.94.2.12
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/6
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/7
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/8
 description LAN/STATE Failover Interface
!
interface Management0/0
 management-only
 nameif mgmt
 security-level 0
 ip address 192.168.2.11 255.255.255.0 standby 192.168.2.12
!
ftp mode passive
pager lines 23
logging enable
logging asdm informational
mtu EXT 1500
mtu INT 1500
mtu mgmt 1500
failover
failover lan unit secondary
failover lan interface LANFAIL GigabitEthernet0/8
failover key *****
failover link LANFAIL GigabitEthernet0/8
failover interface ip LANFAIL 10.10.1.1 255.255.255.0 standby 10.10.1.2
no monitor-interface mgmt
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.2.0 255.255.255.0 mgmt
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpoint _SmartCallHome_ServerCA
 no validation-usage
 crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
telnet timeout 5
ssh stricthostkeycheck
ssh 192.168.2.0 255.255.255.0 mgmt
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
username test password P4ttSyrm33SV8TYp encrypted
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect ip-options
  inspect netbios
  inspect rtsp
  inspect sunrpc
  inspect tftp
  inspect xdmcp
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect esmtp
  inspect sqlnet
  inspect sip
  inspect skinny
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum client auto
  message-length maximum 512
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous prompt 2
call-home
 profile License
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination transport-method http
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:deb136269827f21fc1c142fac079704b
: end

ASAv-Pri#




Video: Cisco ASAv 9.5(1) - High Availability Configuring 


Reference:




NetSec Youtube Videos