Saturday, November 28, 2015

Updating InfoBlox Network Automation Product NetMRI

Infoblox NetMRI product  has been really helpful to manage network environment. The post Use Network Automation Tool Infoblox NetMRI Push Configuration to Multiple Network Devices explains how to do a batch job with some clicks. This post will explain how to update NetMRI product with some learned experience.

There are two methods to update NetMRI software:

1. Automatic Update


This method only works for minor version, such as from 6.8.1 to 6.8.7. If you will need to upgrade from 6.8.x to 6.9.x, you will need manually update process. It will require your NetMRI has Internet connectivity. If your NetMRI does not have internet access, a manual upgrade will be required!

1.1 Set up Auto Update from NetMRI Network Automation Setttings:

NetMRI Auto Update Settings
NetMRI Auto Update Settings


1.2 Execute Autoupdate command from CLI

If you do not want to wait auto update scheduled job done, you also can upgrade your NetMRI by running the "Autoupdate" utility (provided that your NetMRI has internet access)
1.2.1 SSH to the NetMRI Admin shell and login with your Admin credentials
1.2.2 Execute the command: autoupdate
1.2.3 Follow the Install Instructions (This will automatically upgrade your NetMRI and restart it)


NetworkAutomation 1200101022000001
ALL UNAUTHORIZED ACCESS TO THIS SYSTEM WILL BE PROSECUTED TO THE MAXIMUM EXTENT ALLOWED BY APPLICABLE LAWS
Last login: Wed Nov 18 11:20:48 2015 from 10.9.20.4



                Network Automation Administrative Shell

                ---------------------------

Available Commands:

  acl         ftp               md5sum           register    set          
  autoupdate  grep              more             remoteCopy  setup        
  cat         halt              netstat          removedsb   show         
  clear       help              ping             removemib   snmpwalk     
  configure   installdsb        provisiondisk    repair      ssh-key      
  debug       installhelpfiles  quit             reset       supportbundle
  deregister  installmib        rdtclient        restore     telnet       
  diagnostic  license           reboot           rm          tftpsync     
  exit        ls                recalculate-spm  route       top          
  export      maintenance       refreshgroups    sandbox     traceroute   

NetMRI> autoupdate


NOTICE: The inactivity timeout is being disabled temporarily while autoupdate is run.



-------------------------------------------------------------------------

This system has been patched since the last update was applied. It is 
possible that upgrading will overwrite these patches. If you are unsure
about what has been applied, please contact Network Automation support.

The following patches have been applied since your last upgrade:


        2015-07-02 15:53:23 - v6.8-NETMRI-24590

        2015-07-03 03:02:59 - v6.8.8-NETMRI-23483
        2015-07-03 03:03:07 - v6.8.8-NETMRI-24174
        2015-07-03 03:03:15 - v6.8.8-NETMRI-23388
        2015-07-03 03:03:23 - v6.8.8-NETMRI-24294
        2015-08-25 16:57:05 - v6.9.2-CollectAllLogs
        2015-09-04 10:50:58 - v6.8-NETMRI-24590
        2015-11-18 11:25:54 - PreUpgrade-v6.9-CheckServices
-------------------------------------------------------------------------

Do you want to continue, possibly overwriting these patches? (n|y): 


2. Manual Upgrade

You can manually upgrade your NetMRI by downloading the required packages and installing them on a one-by-one basis.

2.1 Goto the Downloads section of the Infoblox Support Center to download the latest software for your NetMRI system

 Note: Please read version release well, some versions may not be compatible with your hardware. For example, Network Automation version 7.02 can not be installed on old platform such as 1102A.

2.2 SCP the files to your NetMRI;

If you're using a command-line version of scp, you may need to specify the destination directory (e.g. scp foo.gpg admin@169.254.1.1:Backup/foo.gpg)

2.3 Starting with the first file, issue the command: autoupdate filename.gpg; *note* the .gpg extension is required

Note: For some major version update, you must to run Network PreUpgrade Check Services patch first.  For example, to upgrade to 6.9.4 version from pre-6.9.1 releases (6.7.3 or 6.8.x), PreUpgrade-v6.9-CheckServices.gpg this patch has to be run first. The check will identify any network services addresses that will need to be changed based on the 6.9.x reconfiguration (for example DNS or NTP server address). It is the customer responsibility to make those changes prior to performing the upgrade. Once the check has been run, the upgrade is permitted.

2.4 Repeat until all packages are installed according to the given upgrade path

Note: please be more patient during update since it may take a while to get all update jobs done. Updatelog shows it took 53 minutes for my NetMRI to complete the process to update from 6.8.8 to 6.9.4.
NetMRI> autoupdate PreUpgrade-v6.9-CheckServices.gpg

NOTICE: The inactivity timeout is being disabled temporarily while autoupdate is run.



+++ Processing Upgrade File PreUpgrade-v6.9-CheckServices.gpg

+++ Checking Digital Signature
+++ Unpacking Upgrade File

-------------------------------------------------------------------------

DESCRIPTION: PreUpgrade-v6.9-CheckServices

Network Automation 6.9 supports network separation between all interfaces.

This introduces a change in behavior between SCAN and MGMT port that may affect
reachability of some network services.

The purpose of this diagnostic is to check connectivity and expected route of any

service that might be affected by this change.

This test runs in two modes

- the more accurate mode requires that the default gateway address
       be applied to the management interface
- the less accurate mode does not.

With the more accurate mode, Network Automation services will be stopped while

the test is made.

With the less accurate mode, services will not be stopped, but there may be

services falsely identified as not available.

It is recommended that the more accurate mode be used.

If you do not know the default gateway, or cannot stop services now,
you can run this in the less accurate mode, and then rerun later.

-------------------------------------------------------------------------


Do you want to apply this patch? (n|y): y


+++ Network Automation is being stopped for the upgrade process ...


+++ Executing Upgrade Script



No services affected by MGMT/SCAN interface route separation. Enabling upgrade.

+++ Network Automation is being restarted ...

NetMRI> autoupdate


NOTICE: The inactivity timeout is being disabled temporarily while autoupdate is run.



-------------------------------------------------------------------------

This system has been patched since the last update was applied. It is 
possible that upgrading will overwrite these patches. If you are unsure
about what has been applied, please contact Network Automation support.

The following patches have been applied since your last upgrade:


        2015-07-02 15:53:23 - v6.8-NETMRI-24590

        2015-07-03 03:02:59 - v6.8.8-NETMRI-23483
        2015-07-03 03:03:07 - v6.8.8-NETMRI-24174
        2015-07-03 03:03:15 - v6.8.8-NETMRI-23388
        2015-07-03 03:03:23 - v6.8.8-NETMRI-24294
        2015-08-25 16:57:05 - v6.9.2-CollectAllLogs
        2015-09-04 10:50:58 - v6.8-NETMRI-24590
        2015-11-18 11:25:54 - PreUpgrade-v6.9-CheckServices
-------------------------------------------------------------------------

Do you want to continue, possibly overwriting these patches? (n|y): n


                                                                                NetMRI> autoupdate v6.9.4-NetworkAutomation-MR-v6.9.4.80404.gpg


NOTICE: The inactivity timeout is being disabled temporarily while autoupdate is run.



+++ Processing Upgrade File v6.9.4-NetworkAutomation-MR-v6.9.4.80404.gpg

+++ Checking Digital Signature
+++ Unpacking Upgrade File

******************************************************************

*                                                                *
*   Infoblox recommends making a backup of the existing network  *
*          database before proceeding with the upgrade           *
*                                                                *
******************************************************************

Do you want to create a network backup? (y/n) [y]: y


Do you want to put backup on local or remote host? (local/remote) [local]: 


Please, choose one of the following (local/remote) [local]: 


Please, choose one of the following (local/remote) [local]: local


Do you want to run this update in the background? (y/n) [y]: y

+++ Network Automation is being stopped for the upgrade process ...

+++ Executing Upgrade Script - use "show updatelog" to check status


NetMRI> show updatelog

2015-11-18 12:12:20     Updating Reset Account ...
2015-11-18 12:12:20         +++ Updating FactoryReset Script ...
2015-11-18 12:12:20     Updating CDR Account ...
2015-11-18 12:12:20     Done Updating CDR Account ...
2015-11-18 12:12:20     Updating Server Files ...
2015-11-18 12:12:24     Configuring Server ...
2015-11-18 12:12:24     Updating Platform Profiles ...
2015-11-18 12:12:24     Updating Health Diagnostic Threshold Files ...
2015-11-18 12:12:24         +++ Editing /tools/skipjack/conf/server.xml ...

2015-11-18 12:12:24         +++ Editing /tools/skipjack/conf


Broadcast message from root@NetMRI (Wed, 18 Nov 2015 12:44:44 -0500):


The system is going down for reboot NOW!


NetworkAutomation 1200101022000001

ALL UNAUTHORIZED ACCESS TO THIS SYSTEM WILL BE PROSECUTED TO THE MAXIMUM EXTENT ALLOWED BY APPLICABLE LAWS
Last login: Wed Nov 18 12:05:29 2015 from 10.9.20.4

                Network Automation Administrative Shell

                ---------------------------
*** NOTICE ***

Successfully Upgraded From Version 6.8.8.77808 to 6.9.4.80404

                                                                     



Reference:


No comments:

Post a Comment

NetSec Youtube Videos