Latest Posts

Comparison of Cisco Integrated Services Routers: (1800,2800,3800) vs (1900,2900,3900) vs 4000

For Branch switches, please check Comparison of Cisco Switches: (2960 vs 3560), (Cisco 3560 X vs 3650 vs 3750-X vs 3850)

Cisco 2900, 3900, and 4000 (4300 and 4400) Series Integrated Services Routers can communicate directly with Cisco Unified Communications Manager, allowing for the deployment of unified communications solutions that are ideal for small and medium-sized businesses, large enterprises, and service providers that offer managed network services.



In addition to everything integrated from previous generations, the ISR 4000 Series introduces several new concepts to branch routing. Separate CPU complexes for control plane and packet processing is nothing new, but the ISR 4K brings this technology down into the Enterprise branch for the first time in an affordable way that looks and feels as familiar as the traditional ISRs. Virtualization of services is a popular solution and the ISR 4K includes both server virtualization as well as a built-in hypervisor for integrating network-focused virtual machines right on the router itself through Service Containers. Add in license-based performance and you have a platform designed to grow with you through additional services and performance without the need to replace hardware in the field or over-buy more capability than you need up front.

ISR 4000 Series address management with support for both traditional network management platforms and models as well as emerging standards. That means they include support for the same IOS CLI, SNMP, and management protocols that have been around for 20 years as well as newer concepts such as REST, SDN, and programmability through Cisco onePK.

Following Cisco table shows the features comparison for First-Generation ISR, 2nd ISR:

Features
1st Generation
(Cisco 1800, 2800,
3800 Series (EOL))
Generation 2 (ISR G2)
(Cisco 1900, 2900,
3900 Series)
Cisco 4000 Series
Integrated Services Routers
Benefits
Maximum   throughput
Up  to  50  Mbps
Up  to  350  Mbps
 Up  to  2  Gbps
4 to 10 times performance increase for the  same price as the ISR G2
Separate data, control,
and   services   planes
x
x
v
Minimal performance impact as network services are added and throughput increases
Integrated  service  container
x
x
v
No need for additional branch appliances; add network services using pluggable virtual machines
Integrated compute with Cisco
UCS®1      E-Series   servers
x
v
v
Local compute resources for applications, data backup, and analytics
Cisco  IOS®  XE Operating  System
x
x
v
Higher availability for network services with multicore processing
Cisco® Application Visibility
and   Control   (AVC)
x
v
v
Visibility into 1000+ applications for capacity planning and prioritization
Intelligent path
selection   (PfR  v3)
x
v
v
Improve application experience and lower costs with path selection using real-time analytics
WAN optimization
(WAAS3     and   Akamai)
x
v
v
Improve application performance and offload WAN with Layer 4–7 optimization and intelligent caching
Sourcefire® Intrusion
Detection   System   (IDS)
x
v
v
Industry-leading advanced threat defense
Cloud  Web  Security with Advanced  Malware  Protection    (AMP)
x
v
v
Scale secure direct Internet access with  consistent policy enforcement
Multicore hardware VPN acceleration
x
x
v
High-performance encryption for secure WAN
Pay-as-you-grow performance
and     services
x
x
v
Ability to buy what you need today and upgrade anytime  without  complete  equipment upgrades
Cisco  ONE  Software  Suites
x
v
v
Predictable OpEx spend, license portability, and investment protection
Intelligent WAN app with Cisco
APIC  Enterprise  Module
x
v
v
Automated provisioning for faster deployment

Figure1:



Evolution of Cisco Branch Routers : from 2500 series to ISR 4000 series
Evolution of Cisco Branch Routers : from 2500 series to ISR 4000 series

More features details for 4000 series:
1. Connectivity Options

2. 4-10X faster

3. Re-designed Architecture For Branch Agility

4. I/O Design


5. Modular ISR Migration Paths from 1900, 2900 and 3900 series

6. Compatibility to ISR G2 (1900, 2900 and 3900) Modules


7. Some Pictures




8. Show Version and Configuration


Router#sh ver
Cisco IOS XE Software, Version 03.16.01a.S - Extended Support Release
Cisco IOS Software, ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.5(3)S1a, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Wed 04-Nov-15 12:50 by mcpre


Cisco IOS-XE software, Copyright (c) 2005-2015 by cisco Systems, Inc.
All rights reserved.  Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0.  The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY.  You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0.  For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.


ROM: IOS-XE ROMMON

Router uptime is 2 weeks, 2 days, 1 hour, 9 minutes
Uptime for this control processor is 2 weeks, 2 days, 1 hour, 10 minutes
System returned to ROM by reload at 04:19:32 UTC Fri Dec 4 2015
System image file is "bootflash:/isr4300-universalk9.03.16.01a.S.155-3.S1a-ext.SPA.bi"
Last reload reason: PowerOn



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
[email protected]

Suite License Information for Module:'esg'

--------------------------------------------------------------------------------
Suite                 Suite Current         Type           Suite Next reboot  
--------------------------------------------------------------------------------
FoundationSuiteK9     None                  None           None              
securityk9
appxk9

AdvUCSuiteK9          None                  None           None              
uck9
cme-srst
cube


Technology Package License Information:

-----------------------------------------------------------------
Technology    Technology-package           Technology-package
              Current       Type           Next reboot
------------------------------------------------------------------
appxk9           None             None             None
uck9             None             None             None
securityk9       securityk9       Permanent        securityk9
ipbase           ipbasek9         Permanent        ipbasek9

cisco ISR4331/K9 (1RU) processor with 1659383K/6147K bytes of memory.
Processor board ID FLM1949D0DZ
7 Gigabit Ethernet interfaces
32768K bytes of non-volatile configuration memory.
4194304K bytes of physical memory.
3207167K bytes of flash memory at bootflash:.

Configuration register is 0x2102

Router#show inventory 
NAME: "Chassis", DESCR: "Cisco ISR4331 Chassis"
PID: ISR4331/K9        , VID: V02, SN: FLM1949D0DZ

NAME: "Power Supply Module 0", DESCR: "250W AC Power Supply for Cisco ISR 4330"
PID: PWR-4330-AC       , VID: V01, SN: PST1931D01G

NAME: "Fan Tray", DESCR: "Cisco ISR4330 Fan Assembly"
PID: ACS-4330-FANASSY  , VID:    , SN:            

NAME: "module 0", DESCR: "Cisco ISR4331 Built-In NIM controller"
PID: ISR4331/K9        , VID:    , SN:            

NAME: "NIM subslot 0/1", DESCR: "NIM-ES2-4"
PID: NIM-ES2-4         , VID: V01, SN: FOC1927D5RR

NAME: "NIM subslot 0/0", DESCR: "Front Panel 3 ports Gigabitethernet Module"
PID: ISR4331-3x1GE     , VID: V01, SN: JAB092709DL

NAME: "module 1", DESCR: "Cisco ISR4331 Built-In SM controller"
PID: ISR4331/K9        , VID:    , SN:            

NAME: "module R0", DESCR: "Cisco ISR4331 Route Processor"
PID: ISR4331/K9        , VID: V02, SN: FDO19451DDM
          
NAME: "module F0", DESCR: "Cisco ISR4331 Forwarding Processor"
PID: ISR4331/K9        , VID:    , SN:  





Router#sh run
Building configuration...



Current configuration : 1361 bytes
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
no aaa new-model
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
!
license udi pid ISR4331/K9 sn FDO19451WHM
!
spanning-tree extend system-id
!
!
redundancy
 mode none
!
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/0/1
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/0/2
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 shutdown
 negotiation auto
!
interface Vlan1
 no ip address
 shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
!
!
!
!
!
control-plane
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end





No comments